jorrit77 / laravel-doctrine by jorrit77
forked from mitchellvanw/laravel-doctrine

The Doctrine 2 implementation that melts with Laravel 4
51
0
1
Package Data
Maintainer Username: jorrit77
Maintainer Contact: mitchell@kooding.nl (Mitchell van Wijngaarden)
Package Create Date: 2014-11-17
Package Last Update: 2018-10-16
Home Page:
Language: PHP
License: MIT
Last Refreshed: 2019-05-14 03:32:59
Package Statistics
Total Downloads: 51
Monthly Downloads: 0
Daily Downloads: 0
Total Stars: 0
Total Watchers: 1
Total Forks: 0
Total Open Issues: 0

Doctrine 2 for Laravel on PHP 5.3

A Doctrine 2 implementation that melts with Laravel 4 on PHP 5.3.

Documentation

This is a fork of package v0.5.0 made by Mitchell van Wijngaarden for an implementation with PHP versions 5.3 or 5.4. Consider this an ugly downgrade only.

  • If you work with Laravel 4 on PHP 7, use: https://github.com/mitchellvanw/laravel-doctrine
  • If you work with Laravel 5 on PHP 7, use: https://github.com/laravel-doctrine/orm

Things done:

  1. Array declarations in square brackets are replaced by function "array()"
  2. The calls to static method "class" for getting fully qualified class names are replaced by literal strings
  3. One anonymous function which called $this now calls $that which is bound to $this earlier. Method mapLaravelToDoctrineConfig() is made public for this purpose only.
  4. Traits are removed